summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2017-04-16 10:42:47 -0400
committerDavid Parrish2017-04-16 10:42:47 -0400
commitd507c9dca8483b24ecfa0a8c3892fa287e9d5f43 (patch)
tree6ccf5d1f804fbc812e771eed39adc2dd800b01f2 /PKGBUILD
downloadaur-d507c9dca8483b24ecfa0a8c3892fa287e9d5f43.tar.gz
Initial commit for habitat
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a9d9ebba877
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=habitat
+pkgver=0.20.0
+pkgrel=1
+pkgdesc="Application automation framework that allows you to build applications that have automation built-in"
+arch=('x86_64')
+url="https://www.habitat.sh/"
+license=('Apache')
+depends=()
+makedepends=('cargo')
+source=("${pkgname}::git+https://github.com/habitat-sh/habitat.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ # Use a temporary local Cargo repository.
+ local CARGO_HOME="${srcdir}/cargo-repository"
+
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+# Commented out because tests ask for sudo access
+#check() {
+# # Use a temporary local Cargo repository.
+# local CARGO_HOME="$srcdir/cargo-repository"
+#
+# cd "${srcdir}/${pkgname}"
+# make test
+#}
+
+package() {
+ # Install executable.
+ ls
+ install -D -m755 "${srcdir}/${pkgname}/target/debug/hab" "${pkgdir}/usr/bin/hab"
+}
+