summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrtc02019-06-17 16:58:55 +0900
committermrtc02019-06-17 16:58:55 +0900
commit9f1a52424010c415b24d6da29a10cf09b5671223 (patch)
treedac1f7ba009964d099855af6f7d56a33ef01fa95 /PKGBUILD
downloadaur-9f1a52424010c415b24d6da29a10cf09b5671223.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f686354eb0b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kohei Morita <mrtc0@ssrf.in>
+pkgname=haconiwa-git
+pkgver=v0.10.2.r15.g375a79b
+pkgrel=1
+pkgdesc="MRuby on Container / A Linux container runtime using mruby DSL for configuration, control and hooks http://haconiwa.mruby.org/"
+arch=('x86_64')
+url="https://github.com/haconiwa/haconiwa"
+license=('GPL')
+depends=('libcgroup' 'criu' 'oniguruma')
+makedepends=('git' 'libcgroup' 'criu' 'oniguruma')
+conflicts=("${pkgname%-git}")
+source=('haconiwa-git::git+https://github.com/haconiwa/haconiwa')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make PREFIX="${pkgdir}/usr/" install
+}