summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarjan Krijan2020-12-23 00:56:19 +0100
committerGitHub2020-12-22 18:56:19 -0500
commit3d6b0b67651d92c32e3294ac8fcaa72666e4695d (patch)
treefc077e4d57bedd054b15d3f1a3291f31cd2b3a21 /PKGBUILD
parent22e65d2c9e3bef15f7c15f3e3ec9bafb1be38395 (diff)
downloadaur-3d6b0b67651d92c32e3294ac8fcaa72666e4695d.tar.gz
[half] Fix a bug in the half.hpp include file not enabling F16C intrinsics correctly when the architecture supports it. (#93)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3270ae31239..507665641ff1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,28 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=half
pkgver=2.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Half-precision floating-point library"
url="http://half.sourceforge.net/"
arch=(x86_64)
license=('MIT')
makedepends=()
depends=()
-source=("${pkgname}-${pkgver}.zip::https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.zip/download")
-sha256sums=("ad1788afe0300fa2b02b0d1df128d857f021f92ccf7c8bddd07812685fa07a25")
+source=(
+ "${pkgname}-${pkgver}.zip::https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.zip/download"
+ "f16c_fix.patch"
+)
+sha256sums=(
+ "ad1788afe0300fa2b02b0d1df128d857f021f92ccf7c8bddd07812685fa07a25"
+ "2f55340a7e2f654487a0ce6467068a142e00a1fa10a118c859a3cdba6070d8c6"
+)
+
+prepare() {
+ # Fix a bug in the half.hpp include file not enabling F16C intrinsics
+ # correctly when the architecture supports it
+ # https://github.com/acxz/pkgbuilds/issues/94
+ patch -p0 ${srcdir}/include/half.hpp < f16c_fix.patch
+}
package() {
mkdir -p ${pkgdir}/usr/include/half