summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosh Marshall2018-04-02 12:25:02 -0400
committerJosh Marshall2018-04-02 12:25:02 -0400
commit4297dbfb15e63c6c4243b6c5a5781704da8a70ce (patch)
treeff6b57935e669024310cde224b0e240530db13e1 /PKGBUILD
downloadaur-4297dbfb15e63c6c4243b6c5a5781704da8a70ce.tar.gz
Initial commit for the HAMAP programs and data files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb05b0966a7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Josh Marshall <jrmarsha@mtu.edu>
+
+pkgname=hamap
+pkgver='2018.april.2'
+pkgrel=1
+pkgdesc='High-quality Automated and Manual Annotation of Proteins.'
+arch=('any')
+license=('custom')
+url='ftp://ftp.expasy.org'
+depends=('')
+makedepends=('bash')
+provides=()
+path='/databases/hamap'
+source=(
+ 'LICENSE'
+ "$url$path/hamap.prf.gz"
+ "$url$path/hamap_alignments.tar.gz"
+ "$url$path/hamap_rules.dat"
+ "$url$path/hamap_seed_alignments.tar.gz"
+ "$url$path/rules_index.dat"
+ )
+md5sums=(
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+)
+
+package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p "$pkgdir/opt/$pkgname/"
+ rm -f *.gz *.tgz
+ find * -maxdepth 0 -regex '.+\.gz|.+\.tgz|LICENSE' -prune -o -print0 | xargs -0 -i cp -rfLH {} "$pkgdir/opt/$pkgname/"
+}