summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Scholz2019-11-04 09:58:32 +0100
committerChristoph Scholz2019-11-04 09:58:32 +0100
commitdb287a7b1170c91ce60b8c0bd2bc14581f927779 (patch)
treeed4fd98bb8bb8b8a1197abc3ea452a2b46bdb4fe /PKGBUILD
downloadaur-db287a7b1170c91ce60b8c0bd2bc14581f927779.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9affff2870bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christoph Scholz <christoph.scholz@gmail.com>
+pkgname=hangul-attack
+pkgver=2.0
+pkgrel=1
+pkgdesc="Game for practicing typing Hangul (Korean alphabet)."
+arch=('any')
+url="https://gobillykorean.com/updated-free-hangul-typing-practice-game-new-version"
+license=('unknown')
+options=("!strip")
+source=("${pkgname}::https://gobillykorean.com/shop/File/get/?file=Hangul_Attack_Linux" "${pkgname}.png::https://gobillykorean.com/wp-content/uploads/2015/12/top_sitebanner.png")
+sha256sums=('74d503380d910dd37cc67df754b7b1ed22caa58f96cc7f158c99451ca6141963' '9912d75ae96e8f8fa380735ba90c6350dd60b8cbede36cc59e0abe95ba89f478')
+
+package() {
+ install -D -m755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ mkdir -p -m755 "${pkgdir}/usr/share/applications/"
+ printf "[Desktop Entry]
+Version=${pkgver}
+Type=Application
+Name=Hangul Attack
+Comment=${pkgdesc}
+Exec=${pkgname}
+Icon=${pkgname}
+Categories=Game
+Terminal=false
+StartupNotify=true
+" >> "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}