summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBilal Elmoussaoui2016-11-14 18:44:19 +0100
committerBilal Elmoussaoui2016-11-14 18:44:19 +0100
commit570b335182c211e49cf559517632392c6b1d5c10 (patch)
treec65c634de97088891c01097a90acdef2c08bc160 /PKGBUILD
downloadaur-570b335182c211e49cf559517632392c6b1d5c10.tar.gz
first repo release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2877116c437e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+
+# Maintainer: Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>
+
+_pkgbase=hardcode-tray
+_gitname=Hardcode-Tray
+pkgname=$_pkgbase
+pkgver=3.5
+pkgrel=1
+pkgdesc="Fixes Hardcoded Tray Icons"
+arch=('i686' 'x86_64')
+url="https://github.com/bil-elmoussaoui/Hardcode-Tray"
+license=('GPL')
+provides=("$_pkgbase")
+conflicts=("hardcode-tray-fixer-git" "hardcode-tray-git")
+depends=('python' 'python-gobject' 'python-cairosvg' 'librsvg' 'gtk3')
+optdepends=('sni-qt-eplus-bzr: patched qt4 sni plugin to enable icon modification' 'inkscape: to convert svg to png with inkscape')
+optdepends_x86_64=('lib32-sni-qt-eplus-bzr: 32-bit patched qt4 sni plugin to enable icon modification')
+source=("https://github.com/bil-elmoussaoui/${_gitname}/archive/v${pkgver}.tar.gz")
+sha256sums=('24324287695a4486a9a3aa7743987dad4f31953a837fd256e2d6afd209ae2795')
+
+package() {
+ install -Dm755 "$srcdir/$_gitname-$pkgver/script.py" "$pkgdir/opt/$_gitname/script.py"
+ install -Dm755 "$srcdir/$_gitname-$pkgver/hardcode-tray" "$pkgdir/usr/bin/hardcode-tray"
+ install -d "$pkgdir/opt/$_gitname"
+ cp -r "$srcdir/$_gitname-$pkgver/database" "$pkgdir/opt/$_gitname"
+}