summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-06-24 20:49:14 +0200
committerBilal Elmoussaoui2017-06-24 20:49:14 +0200
commit631c6ddb2648d5cdd3fa813957f8deda4763df72 (patch)
tree126eb12c3d792727f9a5e0721e190bd7dea69c57 /PKGBUILD
parent8996545d4ea115ede4eda6532cd6ad20b6905428 (diff)
downloadaur-631c6ddb2648d5cdd3fa813957f8deda4763df72.tar.gz
bump version number
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f67107e967cb..56a9c90f90dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,28 @@
_pkgbase=hardcode-tray
_gitname=Hardcode-Tray
pkgname=$_pkgbase
-pkgver=3.8.2
+pkgver=4.0
pkgrel=1
pkgdesc="Fixes Hardcoded Tray Icons"
arch=('i686' 'x86_64')
url="https://github.com/bil-elmoussaoui/${_gitname}"
-license=('GPL')
+license=('GPL-3.0')
provides=("$_pkgbase")
conflicts=("hardcode-tray-fixer-git" "hardcode-tray-git")
+makedepends=('ninja' 'meson')
depends=('python' 'python-gobject' 'python-cairosvg' 'librsvg' 'gtk3')
optdepends=('sni-qt-patched-git: patched qt4 sni plugin to enable icon modification' 'inkscape: to convert svg to png with inkscape' 'imagemagick: used to convert svg to png')
optdepends_x86_64=('lib32-sni-qt-patched-git: 32-bit patched qt4 sni plugin to enable icon modification')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('dafbc450b4a2406375ff24e0d8477a57e399736e979ed0b40e37add3e0824468')
+sha256sums=('432ed1bb9d13e04344838ccd8259f91e4303e82138b3080bad9a52235c313bec')
+
+
+build() {
+ cd "$srcdir/${_gitname}-${pkgver}"
+ meson builddir --prefix=/usr
+}
package() {
- install -Dm755 "$srcdir/$_gitname-$pkgver/hardcode-tray.py" "$pkgdir/opt/$_gitname/hardcode-tray.py"
- install -Dm755 "$srcdir/$_gitname-$pkgver/hardcode-tray" "$pkgdir/usr/bin/hardcode-tray"
- install -d "$pkgdir/opt/$_gitname"
- cp -r -f "$srcdir/$_gitname-$pkgver/src" "$pkgdir/opt/$_gitname"
- cp -r -f "$srcdir/$_gitname-$pkgver/data" "$pkgdir/opt/$_gitname"
+ cd "$srcdir/${_gitname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C builddir install
}