summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThibaut Sautereau2022-01-14 11:16:19 +0100
committerThibaut Sautereau2022-01-14 12:02:45 +0100
commitaaa8063ca2e041776037b2edc33bf3a4e9e5824c (patch)
tree37da0502691d801323835a2d4a715e63e826bd8d /PKGBUILD
parent1d410966e206034c68d4f730654bfbce37b840c8 (diff)
downloadaur-aaa8063ca2e041776037b2edc33bf3a4e9e5824c.tar.gz
Bump to version 10
See https://github.com/GrapheneOS/hardened_malloc/releases/tag/10 as well as https://twitter.com/GrapheneOS/status/1481364976317120512 for information about the new configuration variant system.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00a0d81de3ef..3a38767f6142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thibaut Sautereau (thithib) <thibaut at sautereau dot fr>
pkgname=hardened_malloc
-pkgver=9
+pkgver=10
pkgrel=1
pkgdesc="Hardened allocator designed for modern systems"
arch=('x86_64')
@@ -10,14 +10,15 @@ license=('MIT')
depends=('gcc-libs')
makedepends=('git')
checkdepends=('python')
-provides=('libhardened_malloc.so')
+provides=('libhardened_malloc.so' 'libhardened_malloc-light.so')
source=("git+https://github.com/GrapheneOS/$pkgname#tag=$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('65EEFE022108E2B708CBFCF7F9E712E59AF5F22A') # Daniel Micay <danielmicay@gmail.com>
build() {
cd "$pkgname"
- make
+ make VARIANT=default
+ make VARIANT=light
}
check() {
@@ -27,7 +28,9 @@ check() {
package() {
cd "$pkgname"
- install -Dm755 --target-directory="$pkgdir/usr/lib" libhardened_malloc.so
+ install -Dm755 --target-directory="$pkgdir/usr/lib" \
+ out/libhardened_malloc.so \
+ out-light/libhardened_malloc-light.so
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}