summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuna Tsuki2021-01-24 21:22:51 +0100
committerLuna Tsuki2021-01-24 21:24:07 +0100
commitc5c53c83ee9e0cc98eda8e74386e26424737ea9b (patch)
treef047bfb18118727981086bcd1678303a8b90d5c1 /PKGBUILD
downloadaur-c5c53c83ee9e0cc98eda8e74386e26424737ea9b.tar.gz
Init the AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c7f0602f595
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: mlunax <lunax@mlunax.com>
+
+pkgname=haruhi-dl
+_gitname="haruhi-dl-master"
+pkgver=2021.01.24
+pkgrel=1
+pkgdesc="Fork of youtube-dl, focused on bringing a fast, steady stream of updates. We'll do our best to merge patches to any site, not only youtube."
+arch=('any')
+url="https://haruhi.download"
+license=('custom')
+depends=('python' 'python-setuptools')
+makedepends=('git' 'pandoc')
+optdepends=('ffmpeg: for video post-processing'
+ 'rtmpdump: for rtmp streams support'
+ 'atomicparsley: for embedding thumbnails into m4a files'
+ 'phantomjs: for openload support')
+provides=("haruhi-dl")
+source=('haruhi-dl.tar.gz::https://git.sakamoto.pl/laudompat/haruhi-dl/-/archive/master/haruhi-dl-master.tar.gz')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ python -m haruhi_dl --version
+}
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py
+ sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make pypi-files zsh-completion
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 haruhi-dl.plugin.zsh "${pkgdir}/usr/share/zsh/site-functions/_haruhi-dl"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}