summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShootingStarDragons2023-01-08 18:44:09 +0800
committerShootingStarDragons2023-01-08 18:44:09 +0800
commit0e3d3c14185c95c91c07ac60eeba0b7f27f2624d (patch)
treee6b2dacfbad03fd3451a9267560eea40daaf6ed5 /PKGBUILD
parent446724eb3c7ee31ff39be81cfd817361eae4de92 (diff)
downloadaur-0e3d3c14185c95c91c07ac60eeba0b7f27f2624d.tar.gz
chore: update to 0.2.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 406b1de62d05..c63c769e0069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=haruhishot
-pkgver=0.2.8
-pkgrel=2.0
+pkgver=0.2.9
+pkgrel=1.0
pkgdesc='One day Haruhi Suzumiya made a wlr screenshot tool'
arch=('x86_64' 'aarch64')
url='https://github.com/Decodetalkers/haruhishot'
license=('MIT')
-depends=('wayland' 'wlroots')
+depends=('wayland' 'wlroots' 'qt5-base')
makedepends=('git' 'ninja' 'meson' 'rust' 'wayland-protocols' 'wlroots')
source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/Decodetalkers/haruhishot/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('4a279937816ded7aae9f8cb9acf546eff06c39fecfbcfc48e35d9cc67118477c')
+sha256sums=('1ef74a15b36f97e06d8f46f62ed49545cb4c78fadaffbd2d3af4dd6a7879de4f')
build() {
cd ${pkgname}-$pkgver
@@ -16,6 +16,7 @@ build() {
-Dprefix=/usr \
-Dbuildtype=release \
-Denable-notify=true \
+ -Denable-gui=true \
build
ninja -C build
}