summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Egorov2024-02-07 23:05:49 +0300
committerAlexander Egorov2024-02-07 23:05:49 +0300
commit566dfc08695e1d8044e46976af2c2e068a07d0a8 (patch)
tree7b3342484597eb4127ef5ff1fd934a3b3672f93d /PKGBUILD
downloadaur-566dfc08695e1d8044e46976af2c2e068a07d0a8.tar.gz
hash-calculator-bin v5.3.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17d92b1f7f3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: egoroff <egoroff@gmail.com>
+pkgname=hash-calculator-bin
+pkgver=5.3.0
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Hash Calculator is the console tool that can calculate about 50 cryptographic hashes of strings and files."
+url="https://github.com/aegoroff/hc"
+license=('LGPL-3')
+source=("https://github.com/aegoroff/hc/releases/download/${pkgver}/hc-${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('fc2761e3cc344c3598b50e1525a951632da1848deaca06d4c83d3e1cf675c7c2')
+
+build() {
+ return 0
+}
+
+package() {
+ install -Dm0755 "hc" "$pkgdir/usr/bin/hc"
+ install -Dm0644 "LICENSE.txt" "$pkgdir/usr/share/licenses/grok/LICENSE.txt"
+}