summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:01:17 +0200
committeranthraxx2015-06-18 18:01:17 +0200
commit05d780f721247a71047f1a8f06d1904176263c2f (patch)
treeb3bed1ea3131a0fec50678272f3848ffc8a1e4e7 /PKGBUILD
downloadaur-05d780f721247a71047f1a8f06d1904176263c2f.tar.gz
addpkg: hash-identifier 1.1-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fe36029fc7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Contributor: Mauro Andreolini <mauro.andreolini@unimore.it>
+
+pkgname=hash-identifier
+pkgver=1.1
+pkgrel=3
+pkgdesc="Identify the different types of hashes used to encrypt data and especially passwords"
+url="https://code.google.com/p/hash-identifier/"
+arch=('any')
+license=('GPL3')
+depends=('python2')
+source=(https://hash-identifier.googlecode.com/files/Hash_ID_v${pkgver}.py)
+sha512sums=('af889ebd84d2bd73c9a9623b5573bbb8a4cf5d3ffa6de75b272644905c4c1fa7e5bfcfb24d5ac75ffd73e4305447dd357f16b6248a16424094fc8b8cffca378d')
+
+prepare() {
+ sed -e "s|env python|env python2|" -i Hash_ID_v${pkgver}.py
+ sed -e 's| ||g' -i Hash_ID_v${pkgver}.py
+}
+
+package() {
+ install -Dm 755 Hash_ID_v${pkgver}.py "${pkgdir}/usr/bin/hash-id"
+}
+
+# vim:set ts=2 sw=2 et: