summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGavin Lloyd2019-02-07 10:53:30 -0800
committerGavin Lloyd2019-02-07 10:53:30 -0800
commit15edc3a9b268e49ea133e2797e3f3b28d2795567 (patch)
treeb9d364806f530726c9afe66193709d0774bedd87 /PKGBUILD
downloadaur-15edc3a9b268e49ea133e2797e3f3b28d2795567.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acdcc3bcc000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=hashbrowns-git
+pkgver=0.18.5a3aeb2
+pkgrel=1
+pkgdesc='Provides cryptographic hashes with a minimal UI'
+url='https://github.com/gavinhungry/hashbrowns'
+license=('MIT')
+arch=('any')
+makedepends=('git')
+depends=('pygtk' 'pango' 'python2-pysha3')
+source=("${pkgname}::git+${url}.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo 0.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p "$pkgdir"/usr/bin
+
+ install -m 755 hashbrowns.py "$pkgdir"/usr/bin/hashbrowns
+}