summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2017-01-24 22:23:53 +0100
committeranthraxx2017-01-24 22:23:53 +0100
commitecf52801d7a502c77d813eef0569b1b994502cc2 (patch)
tree12f38d54cc3a53584dea28bfa858330fecb08049 /PKGBUILD
parentc6fa759eb95913ba7beaf56378b1ba9153be9303 (diff)
downloadaur-ecf52801d7a502c77d813eef0569b1b994502cc2.tar.gz
upgpkg: hashcat-git 3.30+43+g55f4d636-1 (adopt to new shared make)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab9d59470957..a5eda2623cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sam Stuewe <halosghost at archlinux dot info>
pkgname=hashcat-git
-pkgver=3.30.3042.bb5663e4
+pkgver=3.30+43+g55f4d636
pkgrel=1
pkgdesc='Multithreaded advanced password recovery utility'
url='https://hashcat.net/hashcat'
@@ -18,20 +18,12 @@ sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" \
- "$(git describe --tags --abbrev=0|sed -r 's|v?(.+)|\1|'|tr '-' '.')" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd ${pkgname}
- sed 's|-Wl,-rpath .||g' -i src/Makefile
+ git describe --tags|sed -r 's|v?(.+)|\1|'|sed 's|-|+|g'
}
build() {
cd ${pkgname}
- make PREFIX=/usr
+ make PREFIX=/usr hashcat_shared
}
package() {