summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-06-23 03:38:34 +0200
committerMichal Wojdyla2021-06-23 03:38:34 +0200
commit8b8bce025252672e5fc03e5439d55461a2591897 (patch)
treeb58da6bd4f1a2df9be03617e61a75cc01079feb1 /PKGBUILD
parentf2c0bfe1faf418a86e488636a0bdb1826d818702 (diff)
downloadaur-hashlibpp.tar.gz
https
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36493b57ac25..b94760bd09a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: allspark <allspark at cyb0rg dot org>
+# Contributor: allspark <allspark at cyb0rg dot org>
pkgname=hashlibpp
pkgver=0.3.4
pkgrel=2
pkgdesc="Hashing library"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/hashlib2plus/"
+url="https://sourceforge.net/projects/hashlib2plus/"
license=('GPL')
groups=()
depends=()
@@ -17,15 +17,15 @@ replaces=()
backup=()
options=()
install=
-source=(http://downloads.sourceforge.net/project/hashlib2plus/$pkgver/hashlibpp_0_3_4.zip Makefile.patch)
+source=(https://downloads.sourceforge.net/project/hashlib2plus/$pkgver/hashlibpp_0_3_4.zip Makefile.patch)
noextract=()
md5sums=('ea5643e92d261258ecefbb92e398c572' '1d62e5ea8125d8a9ff054114956e2851')
build() {
cd $srcdir/hashlib2plus/trunk/src
- patch -p0 -i ../../../Makefile.patch || return 1
+ patch -p0 -i ../../../Makefile.patch
- make -j1 || return 1
+ make -j1
}
package() {
@@ -33,5 +33,5 @@ package() {
mkdir -p "$pkgdir"/usr/lib
mkdir -p "$pkgdir"/usr/include
- make DESTDIR=$pkgdir install || return 1
+ make DESTDIR=$pkgdir install
}