summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbpark2016-12-31 20:19:42 +0900
committercbpark2016-12-31 20:19:42 +0900
commit7b9d7b70a6c883459dda92744b8d188edab50df2 (patch)
tree4073e7d473204d4b33ea303838177e102f68f20c /PKGBUILD
parent6d3a93c7d465d978c75c6451fcfcf8f76319bdd8 (diff)
downloadaur-7b9d7b70a6c883459dda92744b8d188edab50df2.tar.gz
upgpkg: haskell-apply-refact 0.3.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89d6de5a4771..6ef6a285fcdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,19 @@
_hkgname=apply-refact
pkgname=haskell-apply-refact
-pkgver=0.3.0.0
-pkgrel=3
+pkgver=0.3.0.1
+pkgrel=1
pkgdesc="Perform refactorings specified by the refact library"
arch=('i686' 'x86_64')
url="https://hackage.haskell.org/package/${_hkgname}"
license=("custom:BSD3")
-depends=("ghc=8.0.1" "haskell-refact>=0.2" "haskell-ghc-exactprint>=0.5.2" "haskell-syb" "haskell-mtl" "haskell-transformers-base" "haskell-temporary" "haskell-filemanip" "haskell-unix-compat" "haskell-optparse-applicative")
+depends=("ghc>=8.0.1" "haskell-refact>=0.2" "haskell-ghc-exactprint>=0.5.2" "haskell-syb" "haskell-mtl" "haskell-transformers-base" "haskell-temporary" "haskell-filemanip" "haskell-unix-compat" "haskell-optparse-applicative>=0.13")
source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha256sums=('0d2a8845ed554c4a6742a3d0a130dac3f16d0d710b65b20dfeb8e773409ed70f')
+sha256sums=('1754bd300db92fdf668d4698af053d4da686512264275478946b7e0710c5e814')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- sed -i '28 i import Data.Semigroup ((<>))' src/Main.hs
-
runhaskell Setup configure -O --enable-library-profiling --enable-shared \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid