summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbpark2017-06-24 21:20:28 +0900
committercbpark2017-06-24 21:20:28 +0900
commitcf17f56d58d516667c93152324826e49df68620f (patch)
tree15ca0e5e8f923be096a2c85f4dc047122388d79d /PKGBUILD
parentea89e00d97376b22099cdcff8f507224698e8177 (diff)
downloadaur-cf17f56d58d516667c93152324826e49df68620f.tar.gz
upgpkg: haskell-apply-refact 0.3.0.1-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b639bfa2f280..328176e4ee5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,27 @@
_hkgname=apply-refact
pkgname=haskell-apply-refact
pkgver=0.3.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Perform refactorings specified by the refact library"
arch=('i686' 'x86_64')
url="https://hackage.haskell.org/package/${_hkgname}"
license=("custom:BSD3")
depends=("ghc>=8.0.1"
- "haskell-filemanip"
- "haskell-ghc-exactprint>=0.5.2"
- "haskell-mtl"
- "haskell-optparse-applicative>=0.13"
"haskell-refact>=0.2"
+ "haskell-ghc-exactprint>=0.5.2"
"haskell-syb"
- "haskell-temporary"
+ "haskell-mtl"
"haskell-transformers-base"
+ "haskell-temporary"
+ "haskell-filemanip"
"haskell-unix-compat")
-options=('strip')
source=("https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz")
sha256sums=('1754bd300db92fdf668d4698af053d4da686512264275478946b7e0710c5e814')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-library-profiling --enable-shared \
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
@@ -46,4 +44,7 @@ package() {
runhaskell Setup copy --destdir="${pkgdir}"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+
+ # Remove static libs
+ find "$pkgdir"/usr/lib -name "*.a" -delete
}