summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorColin Woodbury2015-07-20 13:43:10 -0700
committerColin Woodbury2015-07-20 13:43:10 -0700
commit725171d15d1488f9a6babe7a09bdf50e33a6571d (patch)
tree2dd78dc934f6ee322fe6dde8644387ca7bb337b8 /PKGBUILD
downloadaur-725171d15d1488f9a6babe7a09bdf50e33a6571d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98899fb35c25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Colin Woodbury <colingw@gmail.com>
+_hkgname=aur
+pkgname=haskell-aur
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Access metadata from the Arch Linux User Repository."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('GPL-3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc'
+ 'haskell-aeson<1'
+ 'haskell-aeson-pretty<1'
+ 'haskell-filepath'
+ 'haskell-lens<5'
+ 'haskell-lens-aeson'
+ 'haskell-mtl'
+ 'haskell-text'
+ 'haskell-vector<0.11'
+ 'haskell-wreq>=0.4')
+options=('strip' 'staticlibs')
+provides=('haskell-aur')
+conflicts=('haskell-aur-git')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+md5sums=('abcb782ec60971db2f42d482984f5fec')
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+}