summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos E. Garcia2016-12-11 15:19:02 -0500
committerCarlos E. Garcia2016-12-11 15:19:02 -0500
commit59742609adab9679325ef765b618f1d921f0222e (patch)
treecfff2ed63016ed46ea0a10ae8064fb049facb7d2 /PKGBUILD
downloadaur-59742609adab9679325ef765b618f1d921f0222e.tar.gz
new to arch, version 0.2.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11d57eec6cd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Carlos E. Garcia <carlos@cgarcia.org>
+_hspkgname=fixed
+pkgname=haskell-fixed
+pkgver=0.2.1.1
+pkgrel=1
+pkgdesc="Signed 15.16 precision fixed point arithmetic"
+arch=('any')
+url="http://github.com/ekmett/fixed"
+license=('custom:BSD3')
+depends=('haskell-base-compat')
+makedepends=('ghc')
+install=${pkgname}.install
+source=(http://hackage.haskell.org/packages/archive/${_hspkgname}/${pkgver}/${_hspkgname}-${pkgver}.tar.gz)
+md5sums=('352e57267013d5c6962311ae266f4715')
+
+build() {
+ cd $_hspkgname-$pkgver
+ runhaskell Setup configure -O2 \
+ --enable-shared \
+ --prefix=/usr \
+ --docdir=/usr/share/doc/$pkgname
+ runhaskell Setup build
+ runhaskell Setup haddock --hyperlink-source
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+}
+
+package() {
+ cd $srcdir/$_hspkgname-$pkgver
+
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -D -m744 CHANGELOG.markdown $pkgdir/usr/share/$pkgname/CHANGELOG.markdown
+
+ install -D -m744 register.sh $pkgdir/usr/share/$pkgname/register.sh
+ install -D -m744 unregister.sh $pkgdir/usr/share/$pkgname/unregister.sh
+
+ runhaskell Setup copy --destdir=$pkgdir
+}
+