summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbpark2017-07-13 21:45:14 +0900
committercbpark2017-07-13 21:45:14 +0900
commitca8e6b7fd7b2e79ee371daa16c53020779c821bf (patch)
tree55e22ecfc350fb350fa02be2c9c4d0decaaa6398 /PKGBUILD
parentc9b9afee489fd30a907166ae9f01b891252f4bde (diff)
downloadaur-ca8e6b7fd7b2e79ee371daa16c53020779c821bf.tar.gz
upgpkg: haskell-ghc-events 0.6.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f48e73cf04a..ce5a4cfe9b9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,19 @@
_hkgname=ghc-events
pkgname=haskell-ghc-events
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Parses .eventlog files emitted by GHC 6.12.1 and later. Includes the ghc-events tool permitting, in particular, to dump an event log file as text."
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
depends=('ghc>=8.0.1')
-options=('strip')
source=("https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz")
sha256sums=('277da9dcd9a1910e530c76b2ad8875868f5e2d8acff44091623dc97255ce0769')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-library-profiling --enable-shared \
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
@@ -37,4 +36,7 @@ package() {
runhaskell Setup copy --destdir="${pkgdir}"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+
+ # Remove static libs
+ find "$pkgdir"/usr/lib -name "*.a" -delete
}