summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 22:27:49 -0400
committerSolomon Choina2018-06-08 22:27:49 -0400
commit390f181f1a1c1fd87d4e043f41e896c83a66f836 (patch)
tree8cf9a15cf824025fbd68bed3696c4438e5b8cdd8 /PKGBUILD
downloadaur-390f181f1a1c1fd87d4e043f41e896c83a66f836.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbde64440cc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-atk
+_hkgname=gi-atk
+pkgver=2.0.15
+pkgrel=1
+pkgdesc="Bindings for Atk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-atk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=("ghc-libs" 'haskell-gi-base' 'haskell-base' 'haskell-bytestring' 'haskell-containers' 'haskell-gi' 'haskell-gi-glib' 'haskell-gi-gobject' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'atk')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('89753b4517e77ea956dcfd1294b4b98032c6e50df912e28c9a796d2b825fbfee')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}