summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien Flament2017-12-08 21:33:19 +0100
committerDamien Flament2017-12-08 21:33:19 +0100
commit1f4cfd4f5dd732284f2f6fe93e7541aff2a0fea5 (patch)
treeb837b74a6e86218e6a0ef9a12523669fa9deb32a /PKGBUILD
downloadaur-1f4cfd4f5dd732284f2f6fe93e7541aff2a0fea5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..917eb65e6741
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Damien Flament <damien.flament at gmx dot com>
+
+_pkgname=haskell-ide-engine
+pkgname=${_pkgname}-git
+pkgver=0.1.0.0
+pkgrel=1
+pkgdesc="The engine for haskell ide-integration. Not an IDE."
+arch=('i686' 'x86_64')
+url="https://github.com/haskell/haskell-ide-engine"
+license=('custom:BSD3')
+depends=()
+makedepends=('git' 'stack')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git://github.com/haskell/${_pkgname}.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ stack build $_STACK_FLAGS
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ stack install --local-bin-path "${pkgdir}/usr/bin"
+}