summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPoscat2019-12-30 07:18:13 +0800
committerPoscat2019-12-30 07:18:13 +0800
commit86c82cb98191e0f4afaf39af7f27f5499f6127a9 (patch)
tree18e6bba9e8f0b62be92a848b64d1dc44385524a7 /PKGBUILD
parent708d28677e0e5beb88d8299a0346379d100b372f (diff)
downloadaur-86c82cb98191e0f4afaf39af7f27f5499f6127a9.tar.gz
Patch source to make it build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dcc03f85aee..2393d4a749f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=haskell-latex-formulae-pandoc
_hkgname=latex-formulae-pandoc
pkgver=0.2.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Render LaTeX formulae in pandoc documents to images with an actual LaTeX installation"
url="https://hackage.haskell.org/package/latex-formulae-pandoc"
license=('BSD')
@@ -13,8 +13,14 @@ depends=('ghc-libs'
'haskell-latex-formulae-image')
makedepends=('ghc')
source=(${pkgname}-${pkgver}.tar.gz::"https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
- )
-sha256sums=('2efc0b9238e237eeacdf3c24f80b7a7546175d4edcb5e86a6f6ffad4769d0c88')
+ cabal.patch)
+sha256sums=('2efc0b9238e237eeacdf3c24f80b7a7546175d4edcb5e86a6f6ffad4769d0c88'
+ 'dd8498cdc786abe005900574f1a05e0932fc74b6f6f25a10756e51a19fca6577')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/cabal.patch"
+}
build() {
cd ${_hkgname}-${pkgver}