summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-11 09:52:30 -0500
committerJaron Kent-Dobias2019-02-11 09:52:30 -0500
commit58dfd4f6ef172f1ca1eaab8e2bc99641dd71a521 (patch)
treed27fc8073d55f6955278710f18c9a70bc17f59fe /PKGBUILD
parent183da7d9457f71b8337a15d445b8ba3c97721af2 (diff)
downloadaur-haskell-linear.tar.gz
bumped version to 1.20.8, added patch to cabal file to build now that semigroups is included in ghc-libs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD90
1 files changed, 46 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e2657de8ff7..a71287300921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,63 @@
-# $Id$
-# Maintainer: Emanuel Couto <unit73e at gmail dot com>
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+# Contributor: Emanuel Couto <unit73e at gmail dot com>
# Contributor: André van Delden <andre.van.delden at uni-bremen dot de>
_hkgname=linear
pkgname=haskell-linear
-pkgver=1.20.7
+pkgver=1.20.8
pkgrel=1
-pkgdesc="Linear Algebra"
-url="http://github.com/ekmett/linear"
+pkgdesc="Types and combinators for linear algebra on free vector spaces."
+url="https://hackage.haskell.org/package/linear"
license=('custom:BSD3')
arch=('i686' 'x86_64')
depends=('ghc-libs'
- 'haskell-adjunctions>=4.0' 'haskell-adjunctions<5'
- 'haskell-base>=4.5' 'haskell-base<5'
- 'haskell-base-orphans>=0.5' 'haskell-base-orphans<1'
- 'haskell-binary>=0.5' 'haskell-binary<0.9'
- 'haskell-bytes>=0.15' 'haskell-bytes<1'
- 'haskell-cereal>=0.4.1.1' 'haskell-cereal<0.6'
- 'haskell-containers>=0.4' 'haskell-containers<0.6'
- 'haskell-deepseq>=1.1' 'haskell-deepseq<1.5'
- 'haskell-distributive>=0.2.2' 'haskell-distributive<1'
- 'haskell-ghc-prim'
- 'haskell-hashable>=1.1' 'haskell-hashable<1.3'
- 'haskell-lens>=4.0' 'haskell-lens<5'
- 'haskell-reflection>=1.3.2' 'haskell-reflection<3'
- 'haskell-semigroupoids>=5.2.1' 'haskell-semigroupoids<5.3'
- 'haskell-semigroups>=0.9' 'haskell-semigroups<1'
- 'haskell-tagged>=0.4.4' 'haskell-tagged<1'
- 'haskell-template-haskell>=2.7' 'haskell-template-haskell<3.0'
- 'haskell-transformers>=0.2' 'haskell-transformers<0.6'
- 'haskell-transformers-compat>=0.4' 'haskell-transformers-compat<1'
- 'haskell-unordered-containers>=0.2.3' 'haskell-unordered-containers<0.3'
- 'haskell-vector>=0.10.0' 'haskell-vector<0.13'
- 'haskell-void>=0.6' 'haskell-void<1')
+ 'haskell-adjunctions'
+ 'haskell-base-orphans'
+ 'haskell-bytes'
+ 'haskell-cereal'
+ 'haskell-distributive'
+ 'haskell-hashable'
+ 'haskell-lens'
+ 'haskell-reflection'
+ 'haskell-semigroupoids'
+ 'haskell-tagged'
+ 'haskell-transformers-compat'
+ 'haskell-unordered-containers'
+ 'haskell-vector'
+ 'haskell-void')
makedepends=('ghc')
-source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('d60e2f5bb3bee1ad71e7756090b91a1268b5f40065300f511bf190629aaa1c6cfc424feb576641517a5ff63d4afaa655bc01326eacf4b304220911486ff9745c')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
+ "haskell-linear-semigroups.patch")
+sha512sums=('7ddb8f394e202d1225864a2bbf5d6b81abb70accb59a634deddc672470418896e3df00e1f7e120bae9e249bf7571ca530be1f511224f818e1ba76e077f99cc77'
+ '4a4d8451982c97cdff35598bea5d0cd892b23382e59a6bc16fdc346ef71ca2471b34fe8e0ace74ca5f0c385e26ba2b7763bb76e7e89732d09e43e190f2af7453')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/haskell-linear-semigroups.patch"
+}
build() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
+ cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
+ cd "${srcdir}/${_hkgname}-${pkgver}"
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
- runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 CHANGELOG.markdown README.markdown -t "${pkgdir}/usr/share/doc/${pkgname}"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: