summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos E. Garcia2016-12-11 15:40:00 -0500
committerCarlos E. Garcia2016-12-11 15:40:00 -0500
commit4c06f105f40f41d2c4589aaf68c81d82482b20d4 (patch)
tree47965e23f76b909b6e61171ba1c06bc2bc100ded /PKGBUILD
parent7f10fe9c0eeae8b89d5566319f731cbf18e9a8d0 (diff)
downloadaur-4c06f105f40f41d2c4589aaf68c81d82482b20d4.tar.gz
updated to version 3.2.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb0c98ab9afc..70c6a82fe7aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Maintainer: Daniel Nagy <danielnagy at gmx de>
# Contributor: Austin Robinson <austin.rbsn@gmail.com>
-_hkgname=OpenGLRaw
+_hspkgname=OpenGLRaw
pkgname=haskell-openglraw
-pkgver=1.5.0.1
+pkgver=3.2.4.0
pkgrel=1
pkgdesc="A raw binding for the OpenGL graphics system"
-url="http://hackage.haskell.org/package/${_hkgname}"
+url="http://hackage.haskell.org/package/${_hspkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
makedepends=()
-depends=('ghc' 'libgl')
+depends=('ghc'
+ 'libgl'
+ 'haskell-text'
+ 'haskell-half'
+ 'haskell-fixed'
+ 'haskell-base-compat'
+ 'haskell-transformers-base'
+ 'haskell-bytestring-builder')
options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+source=(http://hackage.haskell.org/packages/archive/${_hspkgname}/${pkgver}/${_hspkgname}-${pkgver}.tar.gz)
install=${pkgname}.install
-md5sums=('cfb842754fe17a2bdc16f0e155a6aced')
+md5sums=('54553e989777d336c9ae97a45d273701')
build() {
- cd "${srcdir}"/${_hkgname}-${pkgver}
+ cd "${srcdir}"/${_hspkgname}-${pkgver}
runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
--prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
@@ -27,11 +34,11 @@ build() {
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
- cd "${srcdir}"/${_hkgname}-${pkgver}
+ cd "${srcdir}"/${_hspkgname}-${pkgver}
install -D -m744 register.sh "${pkgdir}"/usr/share/haskell/${pkgname}/register.sh
install -m744 unregister.sh "${pkgdir}"/usr/share/haskell/${pkgname}/unregister.sh
install -d -m755 "${pkgdir}"/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hspkgname}
runhaskell Setup copy --destdir="${pkgdir}"
install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
rm -f "${pkgdir}"/usr/share/doc/${pkgname}/LICENSE