summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:31:07 +0200
committerDaniel Nagy2015-06-08 20:31:07 +0200
commit7f10fe9c0eeae8b89d5566319f731cbf18e9a8d0 (patch)
tree8f4021e06f294027991d9dbb09f5ff80cdf5b5c2 /PKGBUILD
downloadaur-7f10fe9c0eeae8b89d5566319f731cbf18e9a8d0.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb0c98ab9afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Austin Robinson <austin.rbsn@gmail.com>
+
+_hkgname=OpenGLRaw
+pkgname=haskell-openglraw
+pkgver=1.5.0.1
+pkgrel=1
+pkgdesc="A raw binding for the OpenGL graphics system"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'libgl')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('cfb842754fe17a2bdc16f0e155a6aced')
+
+build() {
+ cd "${srcdir}"/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd "${srcdir}"/${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}"/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh "${pkgdir}"/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 "${pkgdir}"/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ rm -f "${pkgdir}"/usr/share/doc/${pkgname}/LICENSE
+}