summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbpark2020-07-30 19:05:52 +0900
committercbpark2020-07-30 19:05:52 +0900
commitd4ca6f667149bf17411f1c09f95305e5209e9a1d (patch)
tree46b52de87a521472a8563bb6dfe43963e80844e6 /PKGBUILD
parent8488d07c5311aa7fff8bca68ab2ffa7a951ba3ba (diff)
downloadaur-d4ca6f667149bf17411f1c09f95305e5209e9a1d.tar.gz
upgpkg: haskell-threadscope 0.2.13-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9db90e00e401..b80f42fb8a8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hkgname=threadscope
pkgname=haskell-threadscope
-pkgver=0.2.11.1
+pkgver=0.2.13
pkgrel=1
pkgdesc="A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC)."
url="http://hackage.haskell.org/package/${_hkgname}"
@@ -16,16 +16,17 @@ depends=('ghc-libs'
'haskell-mtl'
'haskell-pango'
'haskell-text'
- 'haskell-file-embed')
+ 'haskell-file-embed'
+ 'haskell-temporary')
makedepends=('ghc')
source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('eb09a4d5db700eaf02f8353e25fb9a2b8b6a070a1196fcd7a5418084d16254b7613e3456a2da0e9e3cec25f7676867336fa85e6d3364138667bb58e7b2238cbb')
+sha512sums=('d8a4c17db945836c0ed552c5b66bde795d7f85bd2e85af8b7c00b6408d31efe082bbf138e9c0436734ab8dc9acb1cb6341a147f8718c3951f95afdedf605539d')
prepare() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- sed -i 's/gtk >= 0.12 && < 0.15,/gtk,/' threadscope.cabal
- sed -i 's/template-haskell < 2.14,/template-haskell,/' threadscope.cabal
+ sed -i 's/gtk >= 0.12 && < 0.16,/gtk,/' threadscope.cabal
+ sed -i 's/template-haskell < 2.16,/template-haskell,/' threadscope.cabal
}
build() {