summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDāvis Mosāns2022-08-16 04:39:45 +0300
committerDāvis Mosāns2022-08-16 04:39:45 +0300
commit8783e83621d5e82a22ccf9968e9c3d2a9b5f3e49 (patch)
treedda1af7a41e25a5e2ce6e95b060c3a04603ec4e9 /PKGBUILD
downloadaur-8783e83621d5e82a22ccf9968e9c3d2a9b5f3e49.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7aac81adce5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+
+_hkgname=yamlparse-applicative
+pkgname=haskell-yamlparse-applicative
+pkgver=0.2.0.1
+pkgrel=1
+pkgdesc="Declaritive configuration parsing with free docs"
+url="https://github.com/NorfairKing/yamlparse-applicative#readme"
+license=("MIT")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-aeson' 'haskell-optparse-applicative' 'haskell-path' 'haskell-path-io' 'haskell-prettyprinter' 'haskell-safe-coloured-text' 'haskell-scientific' 'haskell-unordered-containers' 'haskell-validity' 'haskell-validity-text' 'haskell-vector' 'haskell-yaml')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz" 'Setup.hs')
+sha256sums=('446f674293f7c54dbc485ce7e8bb5028c311ae7036fd394f5f898ce371f998ac'
+ 'f2a37c4a254ff8eb780133ca568ae5f4f4dcdee5219982154e6faef749b8327c')
+
+prepare() {
+ cp Setup.hs "$_hkgname-$pkgver/"
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=haskell-yamlparse-applicative --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}