summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakub Okoński2019-04-13 14:36:06 +0200
committerJakub Okoński2019-04-13 14:36:06 +0200
commit150f4b86926edb275c8f8bd6c94c57e39208bb50 (patch)
tree72c230d2562a18e40bc3cf0ae69f00808e0f2b0e /PKGBUILD
parentbb9fb3d6a28d8b789e4a84ff9c59df6d792f8235 (diff)
downloadaur-150f4b86926edb275c8f8bd6c94c57e39208bb50.tar.gz
Update to 2.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7c3a258c156..b7247bfd6d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Submitter: Olaf Leidinger <oleid@mescharet.de>
# Maintainer: Jakub Okoński <jakub@okonski.org>
pkgname=hcc
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="HCC is an Open Source, Optimizing C++ Compiler for Heterogeneous Compute"
arch=('x86_64')
@@ -14,31 +14,31 @@ conflicts=("${pkgname%-git}")
options=(!staticlibs strip)
source=(
"https://github.com/RadeonOpenCompute/hcc/archive/roc-$pkgver.tar.gz"
- "https://github.com/RadeonOpenCompute/llvm/archive/68584f0b7bc07d43af64f90b3726988b5a513bf9.tar.gz"
- "https://github.com/RadeonOpenCompute/compiler-rt/archive/15e4a1f9195d3d90828a7a122d866c69e650155c.tar.gz"
- "https://github.com/RadeonOpenCompute/hcc-clang-upgrade/archive/c792478f19beee13540053f188094898a008d245.tar.gz"
- "https://github.com/RadeonOpenCompute/clang-tools-extra/archive/b4a0f4adacc1dd5b2deecda2282b20af963716e7.tar.gz"
- "https://github.com/RadeonOpenCompute/lld/archive/8e7027a1bf3b2a0007562d2164e0fa4c037a31d5.tar.gz"
- "https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/381a895a7e80d6ff0785faa21396e66c54d81f85.tar.gz"
+ "https://github.com/RadeonOpenCompute/llvm/archive/87f982f8ce2b85ce824f91bf8c2c90f6843a50a3.tar.gz"
+ "https://github.com/RadeonOpenCompute/compiler-rt/archive/bcfc4b7850d4031918c900877d6d3428e07a06e9.tar.gz"
+ "https://github.com/RadeonOpenCompute/hcc-clang-upgrade/archive/785f31db116e742ac53d052e207979869a857d1a.tar.gz"
+ "https://github.com/RadeonOpenCompute/clang-tools-extra/archive/2e8ff7e2d07754b9d943f7b57b3bfcd5a5102df6.tar.gz"
+ "https://github.com/RadeonOpenCompute/lld/archive/f0cfa52cd79dce6d4d5fcc5105e676c601dc2d3d.tar.gz"
+ "https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/ae81146538cea205c1463c0035f13cd67d3ee44d.tar.gz"
)
sha256sums=(
- "8a1b6d57fe14dcbfdee11aa9cee7d6364f61058cb6f174583f78c68611704864"
- "4667582ff6f49b6e864dd830bf949fe3e7f20873cfa484dab31605fb643afcf8"
- "3c653797405cbbefbb592435a340ad31f8c21467849c49992319ed007081aa7e"
- "fc3a7f7feb6d53cf292be0d6850a71055eaf68a5d28fdcaefb0ee2bac4bb8bc8"
- "348a5ec32737ef17089a706b318fb42ca03dea8fbdbb2b19df4344d27f87ae38"
- "b57ada496b51b799130e0a554a87c50d6675565044ba8a42fd12bf66fd9aa680"
- "a45bba02bdf8b2a5bd6da75af754b427694353c7ef864795b9a7e986350e1a23"
+ "0cdb3a2646db3dd2219bb313d81453b0c16d8152b12c6ed133212480b1962ee2"
+ "28c2ec9fcb2c0d25cbf863fda510666f1aaf324653ac051f3d5ed2897ebc44cc"
+ "b4cabc86ecfef081b6f96ce30ca7288abf97de419cc6524ab1c569562b2b4ac8"
+ "ee5a44efbe90cdc431f2e60121083c71c6765a290d434a78b471a2a52171a105"
+ "19a7e31657e6db3a5b54f230b09730396d05efa354e376e15363cd5deb874e0b"
+ "321aecad28e890831f37817cd395f08a4dd5c0c19d306cd150219fdc369ce885"
+ "4270ceaee17f7c901170d4d3115f53c1ec3554e517b376f7fee11d2e63f66e70"
)
prepare() {
cd "$srcdir"
- mv -T llvm-68584f0b7bc07d43af64f90b3726988b5a513bf9 hcc-roc-$pkgver/compiler
- mv -T compiler-rt-15e4a1f9195d3d90828a7a122d866c69e650155c hcc-roc-$pkgver/compiler-rt
- mv -T hcc-clang-upgrade-c792478f19beee13540053f188094898a008d245 hcc-roc-$pkgver/clang
- mv -T clang-tools-extra-b4a0f4adacc1dd5b2deecda2282b20af963716e7 hcc-roc-$pkgver/clang-tools-extra
- mv -T lld-8e7027a1bf3b2a0007562d2164e0fa4c037a31d5 hcc-roc-$pkgver/lld
- mv -T ROCm-Device-Libs-381a895a7e80d6ff0785faa21396e66c54d81f85 hcc-roc-$pkgver/rocdl
+ mv -T llvm-87f982f8ce2b85ce824f91bf8c2c90f6843a50a3 hcc-roc-$pkgver/compiler
+ mv -T compiler-rt-bcfc4b7850d4031918c900877d6d3428e07a06e9 hcc-roc-$pkgver/compiler-rt
+ mv -T hcc-clang-upgrade-785f31db116e742ac53d052e207979869a857d1a hcc-roc-$pkgver/clang
+ mv -T clang-tools-extra-2e8ff7e2d07754b9d943f7b57b3bfcd5a5102df6 hcc-roc-$pkgver/clang-tools-extra
+ mv -T lld-f0cfa52cd79dce6d4d5fcc5105e676c601dc2d3d hcc-roc-$pkgver/lld
+ mv -T ROCm-Device-Libs-ae81146538cea205c1463c0035f13cd67d3ee44d hcc-roc-$pkgver/rocdl
}
build() {