summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneeshy2020-02-26 20:39:30 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit37dae8ad8e1821808d3a27c17b1ca57123896871 (patch)
treefdf73fdda513260bd584bada3f5816ee82ac6478 /PKGBUILD
parente1182de6bb0f97dfce4b1898663fa9de13f263e8 (diff)
downloadaur-37dae8ad8e1821808d3a27c17b1ca57123896871.tar.gz
Formatting, fix prefixes, and make during build step
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2d7d4c12e87..e8caa2286918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,15 +28,18 @@ prepare() {
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
+
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/hcc" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/hcc \
-DLLVM_INSTALL_UTILS=TRUE \
"$srcdir/hcc-roc-hcc-$pkgver"
make
}
package() {
- make -C "$srcdir/build" install
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
# add links
install -d "$pkgdir/usr/bin"