summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakub Okoński2019-07-14 21:21:15 +0200
committerJakub Okoński2019-07-14 21:21:15 +0200
commit53dd9f7838ef139f10fbd4e1bec9a172abadd581 (patch)
tree7a9db83479b0a0130e71dd8d0c032e0d3b08b84a /PKGBUILD
parent8aa12eb3ce7a925cf2db620539109903e4ec47b5 (diff)
downloadaur-53dd9f7838ef139f10fbd4e1bec9a172abadd581.tar.gz
Update to 2.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c18baaa458a7..9687a1a83b44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Submitter: Olaf Leidinger <oleid@mescharet.de>
# Maintainer: Jakub Okoński <jakub@okonski.org>
pkgname=hcc
-pkgver=2.5.0
+pkgver=2.6.0
pkgrel=1
pkgdesc="HCC is an Open Source, Optimizing C++ Compiler for Heterogeneous Compute"
arch=('x86_64')
@@ -13,32 +13,32 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=(!staticlibs strip)
source=(
- "https://github.com/RadeonOpenCompute/hcc/archive/roc-$pkgver.tar.gz"
- "https://github.com/RadeonOpenCompute/llvm/archive/04d27535fcc4ca8250eaa86e01883c43901cd9ac.tar.gz"
- "https://github.com/RadeonOpenCompute/compiler-rt/archive/0713964c27a5b1766cf53bc83e549f523b2df98e.tar.gz"
- "https://github.com/RadeonOpenCompute/hcc-clang-upgrade/archive/7c03a2e9172656a0832bdb8e0a0c9cd2cbf634a1.tar.gz"
- "https://github.com/RadeonOpenCompute/clang-tools-extra/archive/90ebe0b8bd524c374e7ae71b44458ad1b0eb7307.tar.gz"
- "https://github.com/RadeonOpenCompute/lld/archive/7791abf961afe2591d67b6faee8204d9490631dc.tar.gz"
+ "https://github.com/RadeonOpenCompute/hcc/archive/roc-hcc-$pkgver.tar.gz"
+ "https://github.com/RadeonOpenCompute/llvm/archive/a42c925d178d2a3cd6541769279b736c56b3f935.tar.gz"
+ "https://github.com/RadeonOpenCompute/compiler-rt/archive/28655ce202abf9edbbb309719b7b06be7a8f612d.tar.gz"
+ "https://github.com/RadeonOpenCompute/hcc-clang-upgrade/archive/fff0bd8ccc310cbfec5e3e1bf516b81412081a71.tar.gz"
+ "https://github.com/RadeonOpenCompute/clang-tools-extra/archive/0869af816d464dfcd9541c8ba0eca91c33411cc2.tar.gz"
+ "https://github.com/RadeonOpenCompute/lld/archive/40c741790502f596c316fcf0216433630a8759de.tar.gz"
"https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/6bfe121184303a6ccd731f45e7ba70bf23e4b3d8.tar.gz"
)
sha256sums=(
- "adbc9e358acf9c536c1ac9df87e303c8707d591491693768480a009952cb9413"
- "4cec6a27d078b5af5f0bb82dbf6a426a56fc94697520a288f45d583dc8ef4b5a"
- "ad51e4b0283aa955a5c829580921bf181f8ddee58a2a1398b5e942653c9c57a5"
- "f5896e0479bf8fcfd3dab825950d89625f9c8b4499c5820fd96aa1e47c368b53"
- "45fb7ec6c231f4c422a6a3a76ece5da2ef08d1d586ef1cfff6bee3c94aa32467"
- "58d1cec35dc539f5920856fe46de8daa2ca7ff636c6f06df1796a1e7b4c103b9"
+ "94abf5307bbe20b995f5aa74a1d047e44053af7feacbd0506218889bcf79f938"
+ "fc6e2efc38eeb5d053b57f4f933cd66269db354b89ba7112f86a1430edac4bbe"
+ "d3ade9067237abaf12e749330162ec57605d134f4670e83f3be2df6d22a3a148"
+ "b45e25478b9c9208a040fb3b775f76835aaf88d4367192ab79aceed7b0459db3"
+ "175dbb8d0a59886a93c19a79e34e75932c34d7c9233364035b9b9491483df267"
+ "1987eeea137efe3f95e0e37e4c0df879681497803407143f23dbc71ad22203ea"
"0b933fe27ff1d401c78c3fc805c48268225286fe09ef6028d99967fe94ba382a"
)
prepare() {
cd "$srcdir"
- mv -T llvm-04d27535fcc4ca8250eaa86e01883c43901cd9ac hcc-roc-$pkgver/compiler
- mv -T compiler-rt-0713964c27a5b1766cf53bc83e549f523b2df98e hcc-roc-$pkgver/compiler-rt
- mv -T hcc-clang-upgrade-7c03a2e9172656a0832bdb8e0a0c9cd2cbf634a1 hcc-roc-$pkgver/clang
- mv -T clang-tools-extra-90ebe0b8bd524c374e7ae71b44458ad1b0eb7307 hcc-roc-$pkgver/clang-tools-extra
- mv -T lld-7791abf961afe2591d67b6faee8204d9490631dc hcc-roc-$pkgver/lld
- mv -T ROCm-Device-Libs-6bfe121184303a6ccd731f45e7ba70bf23e4b3d8 hcc-roc-$pkgver/rocdl
+ mv -T llvm-a42c925d178d2a3cd6541769279b736c56b3f935 hcc-roc-hcc-$pkgver/compiler
+ mv -T compiler-rt-28655ce202abf9edbbb309719b7b06be7a8f612d hcc-roc-hcc-$pkgver/compiler-rt
+ mv -T hcc-clang-upgrade-fff0bd8ccc310cbfec5e3e1bf516b81412081a71 hcc-roc-hcc-$pkgver/clang
+ mv -T clang-tools-extra-0869af816d464dfcd9541c8ba0eca91c33411cc2 hcc-roc-hcc-$pkgver/clang-tools-extra
+ mv -T lld-40c741790502f596c316fcf0216433630a8759de hcc-roc-hcc-$pkgver/lld
+ mv -T ROCm-Device-Libs-6bfe121184303a6ccd731f45e7ba70bf23e4b3d8 hcc-roc-hcc-$pkgver/rocdl
}
build() {
@@ -47,7 +47,7 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/hcc" \
-G Ninja \
- "$srcdir/hcc-roc-$pkgver"
+ "$srcdir/hcc-roc-hcc-$pkgver"
ninja
}