summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorspider-mario2015-06-27 15:59:50 +0200
committerspider-mario2015-06-27 16:04:59 +0200
commitda60fd07736ced6271dad9631a1bd0bcb2c92276 (patch)
tree98cf38b1d8d48c3dcf11cfbd7fb96551522a0985 /PKGBUILD
downloadaur-da60fd07736ced6271dad9631a1bd0bcb2c92276.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb9374854a76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: shirokuro <tod dot jackson at gmail dot com>
+# Contributor: giovanni
+
+pkgname=hd2u
+pkgver=1.0.3
+pkgrel=7
+pkgdesc="Dos2Unix text file converter"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://hany.sk/~hany/software/hd2u/"
+depends=('popt')
+conflicts=('dos2unix')
+source=("http://hany.sk/~hany/_data/hd2u/$pkgname-$pkgver.tgz" 'always-false.patch')
+sha512sums=('d354964f0ad5392315767b96438d843a5f1d6afe78da5b0c5ea65a3b0b2a61beabff3ecac89df81b9271a14ca443f23dfffeb51815e02b724ad287e42fc2d6cc'
+ 'fa27ae64ce75fd73ef18207bc46ca8cbdeea66d0d6f3b342d52dbe14a63c23e2c9839bf026382e0c42084a00835235c49039097843b79c2764fe8889a6090ce9')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../always-false.patch
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make BUILD_ROOT="$pkgdir" install
+}