summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorgios Eleftheriou2018-11-05 07:47:57 +0100
committerGeorgios Eleftheriou2018-11-05 07:47:57 +0100
commit998afe648ce3a432c22ae5808c9cbe2fc5a719b2 (patch)
treeead4369479decb64154f305ec701b0b056e80b04 /PKGBUILD
parentccb634937c65e1fe87673fed6d1b29d7f0ed08cc (diff)
downloadaur-998afe648ce3a432c22ae5808c9cbe2fc5a719b2.tar.gz
changes proposed by XavierCLL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff76c9303f54..ec8aac983863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=hdf4
pkgver=4.2.14
-pkgrel=2
+pkgrel=3
pkgdesc="General purpose library and file format for storing scientific data (full version including the FORTRAN and the Java Native Interfaces - JNI)"
arch=('x86_64')
url="https://portal.hdfgroup.org/display/support/HDF+4.2.14"
license=('custom')
-depends=('libaec' 'zlib' 'libjpeg-turbo' 'libtirpc')
+depends=('libaec' 'libjpeg-turbo' 'libtirpc')
makedepends=('java-environment' 'gcc-fortran')
conflicts=('hdf4-java')
provides=('hdf4-java')
@@ -21,7 +21,7 @@ md5sums=('3f3bd5da84015e9221d26fb5a80094b4'
'e17d14ac1d27012c1ea9ac03f783d355')
prepare() {
- [ ! -d build ] && mkdir -p build
+ mkdir -p build
cd "hdf-${pkgver}"
patch < "${srcdir}/config.patch"
autoreconf -i
@@ -32,10 +32,14 @@ build() {
"${srcdir}/hdf-${pkgver}"/configure \
CFLAGS="${CFLAGS} -fPIC" \
+ FFLAGS="${FFLAGS} -fPIC -ffixed-line-length-none" \
LIBS="-ljpeg -laec -lsz" \
F77=gfortran \
JAVADOC='javadoc -Xdoclint:none' \
- --enable-fortran \
+ --enable-shared \
+ --disable-static \
+ --disable-fortran \
+ --disable-netcdf \
--enable-java \
--enable-production \
--with-zlib \