summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12020-06-21 17:41:39 +0800
committerChocobo12020-06-21 18:43:00 +0800
commit1072211f6fd9e32f87d4893963692566b565fbb6 (patch)
tree9212f1a759f93a9778b7bf53a84e78be225f2e19 /PKGBUILD
downloadaur-1072211f6fd9e32f87d4893963692566b565fbb6.tar.gz
newpkg: hdf5-git r36008.gf745476aa5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b768a1f505
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=hdf5-git
+pkgver=r36008.gf745476aa5
+pkgrel=1
+pkgdesc="General purpose library and file format for storing scientific data"
+arch=('i686' 'x86_64')
+url="https://www.hdfgroup.org/solutions/hdf5/"
+license=('custom')
+depends=('glibc' 'bash' 'libaec' 'zlib')
+makedepends=('git' 'cmake') # gcc-fortran
+provides=('hdf5')
+conflicts=('hdf5')
+options=('staticlibs')
+source=("git+https://github.com/HDFGroup/hdf5.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "hdf5"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "hdf5"
+
+ mkdir -p "_build" && cd "_build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DHDF5_BUILD_FORTRAN=OFF \
+ -DHDF5_ENABLE_Z_LIB_SUPPORT=ON \
+ -DHDF5_ENABLE_SZIP_SUPPORT=ON \
+ -DHDF5_ENABLE_SZIP_ENCODING=ON \
+ "../"
+ make
+}
+
+check() {
+ cd "hdf5"
+
+ make test
+}
+
+package() {
+ cd "hdf5"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/hdf5"
+}