summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12020-10-07 13:45:59 +0800
committerChocobo12020-10-07 13:45:59 +0800
commitfc15b79c053daa3c44ad756cd0d3c7669503c8fb (patch)
tree8fd2a618580fbc808a173dde9796a1f367636ff9 /PKGBUILD
parent1072211f6fd9e32f87d4893963692566b565fbb6 (diff)
downloadaur-fc15b79c053daa3c44ad756cd0d3c7669503c8fb.tar.gz
upgpkg: hdf5-git r38283.g66bcfd97a8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3b768a1f505..1d4c1a993e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=hdf5-git
-pkgver=r36008.gf745476aa5
+pkgver=r38283.g66bcfd97a8
pkgrel=1
pkgdesc="General purpose library and file format for storing scientific data"
arch=('i686' 'x86_64')
@@ -27,8 +27,8 @@ pkgver() {
build() {
cd "hdf5"
- mkdir -p "_build" && cd "_build"
cmake \
+ -B "_build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
@@ -36,14 +36,14 @@ build() {
-DHDF5_ENABLE_Z_LIB_SUPPORT=ON \
-DHDF5_ENABLE_SZIP_SUPPORT=ON \
-DHDF5_ENABLE_SZIP_ENCODING=ON \
- "../"
- make
+ ./
+ make -C "_build"
}
check() {
cd "hdf5"
- make test
+ make -C "_build" test
}
package() {