summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2015-06-20 19:53:47 +0200
committerGrey Christoforo2015-06-20 19:53:47 +0200
commit6fa80ecf42e945f20030d1a06f9fe4b1505e7631 (patch)
tree90a7950e8939b369d6da437d3e63913590819b36 /PKGBUILD
downloadaur-6fa80ecf42e945f20030d1a06f9fe4b1505e7631.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41853a3f88f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=hdhomerun_config_gui
+pkgver=20150406
+pkgrel=1
+pkgdesc="GTK2 GUI for configuring the HDHomeRun device"
+arch=('any')
+url="http://www.silicondust.com/downloads"
+license=('GPL3')
+depends=('gtk2' "libhdhomerun=${pkgver}")
+optdepends=('vlc: stream live channels directly from HDHomeRun'
+ 'mythtv: use HDHomeRun as PVR source')
+source=("http://download.silicondust.com/hdhomerun/${pkgname}_${pkgver}.tgz")
+sha1sums=('3f97021379bc32455ea7b357371d6eafaec0209a')
+
+build() {
+ cd $srcdir/$pkgname
+
+ # Thanks to James Edir <jimportal at gmail dot com> for contributing this fix
+ # Updated for builds 20141210 and newer (mrc)
+ sed -i "s|SUBDIRS = ../libhdhomerun src|SUBDIRS = src|g" Makefile.am
+ sed -i "s|-I../../libhdhomerun|-I/usr/include/libhdhomerun|g" src/Makefile.am
+ sed -i "s|-L../../libhdhomerun -lhdhomerun|-lhdhomerun|g" src/Makefile.am
+
+ ./autogen.sh
+
+ make
+}
+
+package() {
+ install -D -m 755 $srcdir/$pkgname/src/hdhomerun_config_gui $pkgdir/usr/bin/hdhomerun_config_gui
+}