summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJános Illés2016-09-21 22:31:16 +0200
committerJános Illés2016-09-21 22:31:16 +0200
commit36c1af70d11c726ce6bba0eb901e8caf9405fa42 (patch)
tree7571cdf782b10ea9be8f2c9acd21c3f111aceebc /PKGBUILD
parent8a73f10de947422ba224292ce806d14c739a81b3 (diff)
downloadaur-36c1af70d11c726ce6bba0eb901e8caf9405fa42.tar.gz
executable's name is different for x86 and x86_64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d8cc68c0db2..aff62401a9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,16 @@ depends=()
if [[ $CARCH == "i686" ]]; then
source=(http://www.hdsentinel.com/hdslin/hdsentinel-016.gz)
md5sums=('4169d8e09265ca9818f6e2d04609461a')
+ _HDSentinel="hdsentinel-016"
elif [[ $CARCH == "x86_64" ]]; then
source=(http://www.hdsentinel.com/hdslin/hdsentinel-016-x64.tar.gz)
md5sums=('2ecf56573fcb8a339fc1b2819d1b96a9')
+ _HDSentinel="HDSentinel"
fi
package() {
cd $srcdir
- install -m755 -D HDSentinel $pkgdir/usr/bin/hdsentinel || return 1
+ install -m755 -D $_HDSentinel $pkgdir/usr/bin/hdsentinel || return 1
}
# vim:set ts=2 sw=2 et: