summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJános Illés2016-09-16 17:20:05 +0200
committerJános Illés2016-09-16 17:20:05 +0200
commit8a73f10de947422ba224292ce806d14c739a81b3 (patch)
tree2c58ee9fbd565d7bc05228d98b05daad8e8a573e /PKGBUILD
downloadaur-8a73f10de947422ba224292ce806d14c739a81b3.tar.gz
initial commit of hdsentinel 0.16 PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d8cc68c0db2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: János Illés <ijanos@gmail.com>
+# Contributor: Borislav Lilov
+pkgname=hdsentinel
+pkgver=0.16
+pkgrel=1
+pkgdesc="A freeware, closed source, SMART analysis tool"
+arch=('i686' 'x86_64')
+url="http://www.hdsentinel.com/hdslin.php"
+license=('unknown')
+depends=()
+if [[ $CARCH == "i686" ]]; then
+ source=(http://www.hdsentinel.com/hdslin/hdsentinel-016.gz)
+ md5sums=('4169d8e09265ca9818f6e2d04609461a')
+elif [[ $CARCH == "x86_64" ]]; then
+ source=(http://www.hdsentinel.com/hdslin/hdsentinel-016-x64.tar.gz)
+ md5sums=('2ecf56573fcb8a339fc1b2819d1b96a9')
+fi
+
+package() {
+ cd $srcdir
+ install -m755 -D HDSentinel $pkgdir/usr/bin/hdsentinel || return 1
+}
+
+# vim:set ts=2 sw=2 et: