summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnthony Ruhier2015-08-09 18:27:56 +0200
committerAnthony Ruhier2015-08-09 18:27:56 +0200
commit98bc7b9c9cf1bb268e7b5a173c4e4ee46e63ebf0 (patch)
tree99d09eb46f7d8368bc96545f32acc221376f3698 /PKGBUILD
downloadaur-98bc7b9c9cf1bb268e7b5a173c4e4ee46e63ebf0.tar.gz
Headphones initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..907fc9b99731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Anthony Ruhier <anthony.ruhier@gmail.com>
+# Many thanks to Justin Dray, maintainer of sickrage, for his PKGBUILD used as
+# a base for this one.
+
+_name=headphones
+pkgname=${_name}
+pkgver=0.5.8
+pkgrel=1
+pkgdesc="Headphones is an automated music downloader for NZB and Torrent, written in Python. It supports SABnzbd, NZBget, Transmission, µTorrent and Blackhole."
+arch=('any')
+url="https://github.com/rembo10/${_name}"
+license=('GPL3')
+depends=('python2')
+optdepends=('sabnzbd: NZB downloader'
+ 'python2-notify: desktop notifications'
+ 'unrar: automatic decompression'
+ 'git: pull new versions from git')
+conflicts=("${_name}-git")
+replaces=("${_name}-git")
+options=('!strip')
+install="${_name}.install"
+source=("${url}/archive/v${pkgver}.tar.gz"
+ "${_name}-system.service"
+ "${_name}-user.service"
+ "${_name}.tmpfile")
+sha256sums=('3c3c1da57417d0d370498598c5d1c7ccf994d77c99d802127cdad73e1fea28b5'
+ '14f00904135940e00a6af5742116d950be07248a578c2562373413155f768d01'
+ '22d2a8da5cc8da149ddac086e52c0e30b51671644e039d435f853cf383f15317'
+ 'b8f7030f570e7707eb9c0f41c382e37d54244e7885c795a9f31788efdd45914e')
+
+package() {
+ mkdir -p "${pkgdir}/opt/${_name}"
+ chmod 775 "${pkgdir}/opt/${_name}"
+ cp -r ${_name}-${pkgver}/* "$pkgdir/opt/${_name}"
+ touch "$pkgdir/opt/${_name}/config.ini"
+
+ install -D -m644 ${_name}-system.service "$pkgdir/usr/lib/systemd/system/${_name}.service"
+ install -D -m644 ${_name}-user.service "$pkgdir/usr/lib/systemd/user/${_name}.service"
+ install -D -m644 ${_name}.tmpfile "$pkgdir/usr/lib/tmpfiles.d/${_name}.conf"
+
+ find "$pkgdir" -type d -name '.git' -exec rm -r '{}' +
+}
+
+# vim: set ts=2 sw=2 ft=sh noet: