summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2017-12-03 21:27:24 +0000
committerWill Handley2017-12-03 21:27:24 +0000
commitcba465f09c914ee3f0548931501237b7fa1cc5ba (patch)
tree36c92a76f4a3668ee273b536c44a33c6a826f375 /PKGBUILD
parent52311fa5ebaad1b9c36003b9c1f1015c1b921cf3 (diff)
downloadaur-cba465f09c914ee3f0548931501237b7fa1cc5ba.tar.gz
Kevin Meagher's autotools updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b01240a59c67..2c3e9addc3ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=healpix
_pkgname=${pkgname}
pkgver='3.31_2016Aug26'
_dir='Healpix_3.31'
-pkgrel=4
+pkgrel=5
pkgdesc="Software for pixelization, hierarchical indexation, synthesis, analysis, and visualization of data on the sphere."
arch=(any)
url="https://sourceforge.net/projects/healpix/"
-license=('unknown')
+license=('GPLv2')
groups=()
-depends=()
+depends=(cfitsio)
makedepends=()
provides=()
conflicts=()
@@ -20,16 +19,24 @@ install=
source=("${url}/files/${_dir}/Healpix_${pkgver}.tar.gz")
sha256sums=('ddf437442b6d5ae7d75c9afaafc4ec43921f903c976e25db3c5ed5185a181542')
build() {
- cd "${srcdir}/${_dir}"
- cp ../../Makefile ${srcdir}/${_dir}
- mkdir -p lib include
- make -j
+ cd "${srcdir}/${_dir}/src/C/autotools"
+ autoreconf --install
+ ./configure --prefix="${pkgdir}/usr"
+ make
+
+ cd "${srcdir}/${_dir}/src/cxx/autotools"
+ autoreconf --install
+ ./configure --prefix="${pkgdir}/usr"
+ make
}
+
#check() {
# cd "${srcdir}/${_dir}"
#}
package() {
- cd "${srcdir}/${_dir}"
- install -Dm755 lib/libchealpix.so "$pkgdir/usr/lib/libchealpix.so"
- install -Dm755 include/chealpix.h "$pkgdir/usr/include/chealpix.h"
+ cd "${srcdir}/${_dir}/src/C/autotools"
+ make install
+ cd "${srcdir}/${_dir}/src/cxx/autotools"
+ make install
}
+