summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Sarboni2018-12-03 14:49:48 +0100
committerThomas Sarboni2018-12-03 14:49:48 +0100
commit73a8cf4d08086bc864ed4b0af191ad9e58a68e11 (patch)
tree1803ce5203b6bd8ec91317a82532f91474ee38ef /PKGBUILD
downloadaur-73a8cf4d08086bc864ed4b0af191ad9e58a68e11.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a64f30c51f72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: max-k <max-kATpostDOTcom>
+
+pkgname=heketi-client
+_pname=${pkgname%%-client}
+_shortname=${_pname}-cli
+pkgver=8.0.0
+pkgrel=1
+pkgdesc="RESTful based volume management framework for GlusterFS (client)"
+arch=('x86_64')
+url="https://github.com/heketi/heketi"
+license=('APACHE' 'GPL2')
+depends=('glibc')
+source=("https://github.com/$_pname/$_pname/releases/download/v$pkgver/$pkgname-v$pkgver.linux.amd64.tar.gz")
+sha256sums=('72505efee7064c005dac59006aac8af4c4ae17ca7b4129271723add1cf43e149')
+
+build() {
+ echo > /dev/null
+}
+
+package() {
+ cd "$srcdir"/"$pkgname" || exit 1
+ install -dm755 "$pkgdir"/usr/{bin,share}
+ install -dm755 "$pkgdir"/usr/share/"$pkgname"/{kubernetes,openshift}
+ install -dm755 "$pkgdir"/usr/share/"$pkgname"/openshift/templates
+ for target in kubernetes openshift; do
+ [[ "$target" == "openshift" ]] && tpl="templates/"
+ install -m755 share/"$_pname"/"$target"/"$tpl"* \
+ "$pkgdir"/usr/share/"$pkgname"/"$target"/"$tpl"
+ done
+}