summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Feletto2020-07-27 14:53:15 +0200
committerAndrea Feletto2020-07-27 14:53:15 +0200
commit072ed80bebd04d4fc55fd41bc8e4d3811f961f03 (patch)
treed044335e2a96b69ba3aa1c53ef366c58be114897 /PKGBUILD
downloadaur-072ed80bebd04d4fc55fd41bc8e4d3811f961f03.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0f6c7dd027c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Heliocron
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=heliocron-git
+_pkgname=${pkgname%-*}
+pkgver=0.4.0.r4.g89ae185
+pkgrel=1
+pkgdesc='Execute tasks relative to sunset, sunrise and other solar events.'
+arch=('x86_64')
+url='https://github.com/mfreeborn/heliocron'
+license=('Apache' 'MIT')
+provides=('heliocron')
+conflicts=('heliocron-bin')
+makedepends=('rust')
+source=("git+https://github.com/mfreeborn/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+#
+# currently not all tests are passed, but binary works
+#
+# check() {
+# cd "$srcdir/$_pkgname"
+# env CARGO_INCREMENTAL=0 cargo test --release
+# }
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}
+