summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2018-07-17 16:46:23 +0200
committerChristopher Arndt2018-07-17 16:46:23 +0200
commit9f5ecd687285a60606aad2e3c2610af23a230a5b (patch)
tree2d3349116e204d0f45d03327d13410d14a2bb9d5 /PKGBUILD
parentbe1f609b4908735c22f1430ee624265353535953 (diff)
downloadaur-9f5ecd687285a60606aad2e3c2610af23a230a5b.tar.gz
Remove 'prepare' function and extra CXXFLAGS; updated dependencies
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 5 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f901ffd17fe..04c6e3d05e82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=helm
pkgname="${_pkgname}-git"
-pkgver=0.9.0.r1876.927d2ed2
+pkgver=0.9.0.r1897.abdedd52
pkgrel=1
pkgdesc="a cross-platform, polyphonic synthesizer LV2 and VST plugin"
arch=('i686' 'x86_64')
url="http://tytel.org/helm/"
license=('GPL')
groups=('lv2-plugins' 'vst-plugins')
-depends=('alsa-lib' 'freetype2' 'mesa' 'lv2')
-makedepends=('git' 'steinberg-vst36')
+depends=('alsa-lib' 'curl' 'freetype2' 'hicolor-icon-theme' 'mesa' 'libxinerama' 'lv2')
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/mtytel/helm.git")
@@ -18,27 +18,6 @@ md5sums=('SKIP')
changelog=ChangeLog
-prepare() {
- cd "$srcdir/${_pkgname}"
-
- msg2 "Fixing Makefiles..."
- sed -i -e "s|-I ~/srcs/VST3\\\\ SDK||" \
- builds/linux/VST/Makefile
-
- for build in standalone/builds/linux builds/linux/VST builds/linux/LV2; do
- sed -i -e 's|JUCE_INCLUDE_PNGLIB_CODE=0|JUCE_INCLUDE_PNGLIB_CODE=1|g' \
- "$build/Makefile"
- done
-
- msg2 "Fixing VST3 SDK include paths in JUCE sources..."
- for file in \
- JUCE/extras/Projucer/Source/Utility/jucer_StoredSettings.cpp \
- JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp \
- JUCE/modules/juce_audio_processors/format_types/juce_VST3Headers.h; do
- sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
- done
-}
-
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -46,18 +25,15 @@ pkgver() {
echo "${ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-
build() {
cd "${srcdir}/${_pkgname}"
- CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
- make PREFIX="/usr" all vst
+ make CONFIG=Release PREFIX="/usr" all vst
}
package() {
cd "${srcdir}/${_pkgname}"
- CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
- make DESTDIR="$pkgdir" install
+ make CONFIG=Release PREFIX="/usr" DESTDIR="$pkgdir" install
install -D builds/linux/VST/build/helm.so "$pkgdir/usr/lib/vst/helm.so"
}