summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2017-07-11 20:49:21 +0200
committerChristopher Arndt2017-07-11 20:49:21 +0200
commitbe1f609b4908735c22f1430ee624265353535953 (patch)
tree45e502a78dd6f72fc6fd08df7c0a74b73f11ab40 /PKGBUILD
parent6a237f706b71d68ef20c93d39c21523aa79c481b (diff)
downloadaur-be1f609b4908735c22f1430ee624265353535953.tar.gz
Fixed two build issues
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44418da92f70..5f901ffd17fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=helm
pkgname="${_pkgname}-git"
-pkgver=0.8.5.r1458.6dbcd64
+pkgver=0.9.0.r1876.927d2ed2
pkgrel=1
pkgdesc="a cross-platform, polyphonic synthesizer LV2 and VST plugin"
arch=('i686' 'x86_64')
@@ -32,7 +32,7 @@ prepare() {
msg2 "Fixing VST3 SDK include paths in JUCE sources..."
for file in \
- JUCE/extras/Introjucer/Source/Utility/jucer_StoredSettings.cpp \
+ JUCE/extras/Projucer/Source/Utility/jucer_StoredSettings.cpp \
JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp \
JUCE/modules/juce_audio_processors/format_types/juce_VST3Headers.h; do
sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
@@ -50,14 +50,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
make PREFIX="/usr" all vst
}
package() {
cd "${srcdir}/${_pkgname}"
- CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
make DESTDIR="$pkgdir" install
install -D builds/linux/VST/build/helm.so "$pkgdir/usr/lib/vst/helm.so"
}