summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLancia2022-10-29 01:12:19 +0330
committerLancia2022-10-29 01:12:19 +0330
commit9f93e28c410e0e1d65f69f1822c60fbe3b892f6d (patch)
tree39333694ccc7bba756593acc1a8d9ed5c121a765 /PKGBUILD
parent626ac6d92868220cbc84ab1ab916f8188c1eb639 (diff)
downloadaur-9f93e28c410e0e1d65f69f1822c60fbe3b892f6d.tar.gz
Added pkgver() function, bumped release number to 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63758e746b44..2324285d2f62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lancia Greggori <lanciagreggori@gmail.com>
pkgname='herbe-git'
-pkgver='1.0.0'
-pkgrel='1'
+pkgver='1.0.0.r10.gdec89e4'
+pkgrel='2'
pkgdesc='Daemon-less notifications without D-Bus'
arch=('x86_64')
url='https://github.com/dudik/herbe'
@@ -10,16 +10,21 @@ depends=('libx11' 'libxft')
makedepends=('git')
provides=('herbe')
conflicts=('herbe')
-source=("$pkgname-$pkgver::git+$url")
+source=("$pkgname::git+$url")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make clean all
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make PREFIX='/usr' DESTDIR="$pkgdir/" install
install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}