summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitc5734bdf7fb447196f87961b9e8d6a8d97dbee20 (patch)
treef0599bb6e3b27dddc747120c6e10753ec79b0eee /PKGBUILD
downloadaur-hercules.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..012a2de19e23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer:
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=hercules
+pkgver=3.13.00
+pkgrel=3
+pkgdesc='Software implementation of System/370 and ESA/390'
+arch=('x86_64')
+url='http://www.hercules-390.eu/'
+license=('custom')
+depends=('bzip2' 'libnsl' 'zlib')
+options=('!makeflags')
+source=("http://downloads.hercules-390.eu/$pkgname-${pkgver%.00}.tar.gz")
+sha512sums=('76f75ef3f1eb10c0fac0d6fa1ab9809b8d1dfe3deccbcd69366b05ee58f1ecb8ea0f387f7201ab4722b121478676f00e707ad27b6ecf1980fb09e900de63d718')
+
+prepare() {
+ ln -sf "$pkgname-${pkgver%.00}" p
+ # Change module extension from .la to .so.
+ sed '/HDL_MODULE_SUFFIX/ s/\.la/.so/' -i p/hdl.h
+}
+
+build() {
+ cd p
+ ./configure --prefix=/usr --enable-optimization=-O3
+ make
+}
+
+package() {
+ cd p
+ DESTDIR="$pkgdir" make install
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/hercules/qpl1"
+}
+
+# vim: ts=2 sw=2 et:
+# getver: raw.githubusercontent.com/rbowler/spinhawk/master/makemsi/Hercules-W64.VER