summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Cholasta2015-05-19 18:48:47 +0200
committerJan Cholasta2015-05-20 06:14:51 +0200
commit092c182657644f1d4bf3f7aeceafd8f8decbb28e (patch)
treee10e0183afa39ffa08290901269976d9cbba80c8 /PKGBUILD
parent9e054c4d2ff17451121531c470f05b4b20a3812d (diff)
downloadaur-092c182657644f1d4bf3f7aeceafd8f8decbb28e.tar.gz
Add prepare() and package() functions where missing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d89452e8dbe5..6baf9ed063fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,15 @@ license=('custom')
source=(ftp://ftp.fu-berlin.de/pc/msdos/games/idgames/idstuff/heretic/htic_v12.zip)
md5sums=('420b23b3d8f2cbd164c121369eaa2b09')
-build() {
+prepare() {
cd "$srcdir"
cat HTIC_V12.1 HTIC_V12.2 > HTIC_V12.EXE
unzip -o HTIC_V12.EXE HERETIC1.WAD LICENSE.DOC || return 1
+}
+
+package() {
+ cd "$srcdir"
install -Dm644 HERETIC1.WAD "$pkgdir"/usr/share/games/heretic/heretic1.wad
install -Dm644 LICENSE.DOC "$pkgdir"/usr/share/licenses/$pkgname/LICENSE