summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian MARGAINE2015-12-27 23:56:31 +0100
committerFlorian MARGAINE2015-12-27 23:56:31 +0100
commit84ea4cfa5e2c619df95f971a47d60fc7c697a9f6 (patch)
tree8eb84f00c6ab756f91a17578bb414e680c0eaed4 /PKGBUILD
parente88d4852724aa182cd4ff78082e1e6228258f1c5 (diff)
downloadaur-84ea4cfa5e2c619df95f971a47d60fc7c697a9f6.tar.gz
Fix install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 31 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 925d3e667144..ae797ca175ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Authenticate on linux by plugging your USB stick!"
arch=(x86_64)
url="https://github.com/ralt/hermes"
license=('MIT')
-depends=(pam libfixposix)
+depends=(pam)
makedepends=(sbcl wget buildapp libfixposix pam)
options=(!strip)
install=
@@ -21,4 +21,34 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ # /lib is deprecated in arch
+ mkdir -p $pkgdir/usr/lib/security
+ mv $pkgdir/lib/security/pam_hermes.so $pkgdir/usr/lib/security/pam_hermes.so
+ rm -rf $pkgdir/lib/
+
+ mkdir -p $pkgdir/usr/share/licenses/hermes
+ cat > $pkgdir/usr/share/licenses/hermes/LICENSE <<EOF
+The MIT License (MIT)
+
+Copyright (c) 2015 Florian Margaine
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+EOF
+
}