summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRedrield2017-09-07 11:41:00 -0400
committerRedrield2017-09-07 11:41:00 -0400
commit28fd1a9e217403af9cfbc65d57d6c2ac843a200e (patch)
treebc480bc6ba118f057711609052c9ba70054b5624 /PKGBUILD
parent265695104bb82042fa349b8f844c861beae06a2d (diff)
downloadaur-28fd1a9e217403af9cfbc65d57d6c2ac843a200e.tar.gz
Lock version to 6.14.20. Improve structure of build file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1339dd615ba..25e89ebbf9e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Rhys Kenwell <redrield+aur@gmail.com>
pkgname=heroku-cli
-pkgver=6.14.16
-pkgrel=1
+pkgver=6.14.20
+pkgrel=2
+_arch=$(uname -m | sed -e "s/86_//; s/i686/x86/")
+_dirname="${pkgname}-v${pkgver}-737bba7-linux-${_arch}"
pkgdesc="a tool for creating and managing Heroku apps from the command line"
arch=('i686' 'x86_64')
url="https://devcenter.heroku.com/articles/heroku-cli"
@@ -9,24 +11,18 @@ license=('custom' 'ISC')
optdepends=('git: Deploying to Heroku')
provides=('heroku-cli')
conflicts=('heroku-cli' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
-source_x86_64=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz')
-source_i686=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz')
-md5sums_i686=('12d109374a5c7fc9e1d85c86445d09be')
-md5sums_x86_64=('9e7b3bbf44bb9c2263ccc6ce2c99bfb6')
-
-prepare() {
- cd "${srcdir}"
- dir=$(find . -type d -regextype sed -regex ".*/heroku-cli-.*" | head -n1)
- mv $dir heroku-cli
-}
+source_i686=("https://cli-assets.heroku.com/heroku-cli/channels/stable/${_dirname}.tar.gz")
+source_x86_64=("https://cli-assets.heroku.com/heroku-cli/channels/stable/${_dirname}.tar.gz")
package() {
cd "${srcdir}"
install -dm 755 "${pkgdir}"/opt
install -dm 755 "${pkgdir}"/usr/bin
- install -Dm 644 heroku-cli/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${_dirname}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- mv heroku-cli "${pkgdir}"/opt/heroku-cli
+ mv "${_dirname}" "${pkgdir}"/opt/heroku-cli
ln -s /opt/heroku-cli/bin/heroku "${pkgdir}"/usr/bin/heroku
}
+md5sums_i686=('9ccef74dcbf7e98afbf964b75da8a66f')
+md5sums_x86_64=('5f19a330f2a3a1f71bc1db3d8f5cf4b3')