diff options
author | Emiel Wiedijk | 2018-07-27 11:25:55 +0200 |
---|---|---|
committer | Emiel Wiedijk | 2018-07-27 11:25:55 +0200 |
commit | fae64670af3043d248da8435948fe06ffceaecab (patch) | |
tree | 5efd21879a5092da2aad154895a7a5f6d511b77a /PKGBUILD | |
parent | a2dd993cfff38fcd4399b29da1a48ffef8cd9b3c (diff) | |
download | aur-fae64670af3043d248da8435948fe06ffceaecab.tar.gz |
Work around world writeable directories npm bug
Apparantely npm makes some directories of this package world writable,
in the node_modules directory of heroku. This obviously should not happen,
to work around this issue, set the directory permissions to 755 manually
using 'find'.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -21,4 +21,7 @@ package() { npm install -g --user root --prefix "$pkgdir/usr" heroku-$pkgver.tgz mkdir -p "$pkgdir/usr/share/licenses/$pkgname" ln -s "../../../lib/node_modules/heroku/LICENSE" "$pkgdir/usr/share/licenses/$pkgname" + + # npm makes some directories world writable + find "$pkgdir/usr" -type d -exec chmod 755 '{}' + } |