summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-07-27 11:25:55 +0200
committerEmiel Wiedijk2018-07-27 11:25:55 +0200
commitfae64670af3043d248da8435948fe06ffceaecab (patch)
tree5efd21879a5092da2aad154895a7a5f6d511b77a /PKGBUILD
parenta2dd993cfff38fcd4399b29da1a48ffef8cd9b3c (diff)
downloadaur-fae64670af3043d248da8435948fe06ffceaecab.tar.gz
Work around world writeable directories npm bug
Apparantely npm makes some directories of this package world writable, in the node_modules directory of heroku. This obviously should not happen, to work around this issue, set the directory permissions to 755 manually using 'find'.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e25ce274019f..1340907b3f81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,4 +21,7 @@ package() {
npm install -g --user root --prefix "$pkgdir/usr" heroku-$pkgver.tgz
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
ln -s "../../../lib/node_modules/heroku/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+
+ # npm makes some directories world writable
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
}